解决WordPress程序PHP版本过低的方法和思路

如果我们比较关注WordPress程序新版本的话会看到自己在网站后台提示有新的WordPress程序需要升级的时候,如果我们当前的WEB系统PHP版本低于5.6版本是无法点击按钮在线直接升级的。因为从WordPress5.2版本开始需要最低PHP5.6,而且根据官方提供的信息可能后面会要求PHP7.x+。(参考:WordPress 5.2版本正式发布 PHP版本最低需要PHP5.6.20

也就是说,如果我们在使用WordPress程序的时候,如果希望用到新版本,你必须是PHP5.6+,如果不升级你是无法使用新版本WP的,就这么任性。那如果我们当前WEB系统不支持PHP5.6+如何办呢?

第一、如果我们是虚拟主机

如果我们使用的是虚拟主机,比如是cPanel面板的话,一般商家都是支持在线调整PHP版本的。我们需要登录cPanel面板,然后在PHP版本设置中选择当前站点,然后选择需要调整的PHP版本。我们需要检查当前网站主题、插件是否支持设置的PHP版本,有些网友喜欢选择最高PHP7.3,但是有些插件或者主题不支持,那我们就适当的调低。

第二、如果我们是服务器

如果我们是服务器,我们需要看看自己的WEB套件是否支持安装多版本PHP软件。比如我们是安装的宝塔面板,或者其他WEB面板是可以安装多版本PHP版本的。(参考:宝塔面板安装多PHP版本切换及不同站点设置不同PHP环境)在安装PHP版本之后对站点进行PHP选择更换。

同样的我们需要检查主题和插件是否兼容。不过,如果我们是自己编译的WEB系统,我们需要手动调整,如果自己不熟悉的话,建议还是老老实实备份数据后重新格式化后安装WEB系统套装。老蒋个人建议,目前PHP可以安装到7.2版本或者直接升级到PHP7.3最新,目前也是稳定版。

总结,老蒋建议网友升级到WP最新版本,因为涉及到安全问题,虽然我也比较讨厌他们一直升级版本,但是又能怎样?

本文出处:老蒋部落 » 解决WordPress程序PHP版本过低的方法和思路 | 欢迎分享( 公众号:QQ69377078 )