解决安装网站主题出现"this will throw an Error in a future version of PHP"问题

刚才老蒋在外面办事儿的时候,有网友联系到自己在搭建网站的时候出现故障,他告诉我是有乱码出现。我开始以为是编码问题,我还留言让他检查下编码。谁知道,实际上是因为网站出现故障代码,但是网站打开还是没有问题的,只不过有报错提醒。

 Warning: Use of undefined constant  (this will throw an Error in a future version of PHP) in /www/wwwroot/itbulu.com/wp-content/themes/lusongsong/index.php on line 29

实际上从字面上看,就知道PHP版本的问题。这里我去看看他的PHP版本是什么。

解决安装网站主题出现"this will throw an Error in a future version of PHP"问题

这里看到他的PHP版本是7.3的,当然这个面板还是我前几天给他安装的。可见他当前的网站主题估计不兼容7.0+,所以我要给他安装一个旧版本。

这里很直观的通过工具安装5.6版本PHP。

然后老蒋再去当前站点切换到PHP版本。检查当然问题解决。

是不是很速度?

这里我们可以看看其他有关PHP版本更换的方法:

1、阿里云虚拟主机修改PHP版本的方法 且需要修改数据库加密模式

2、解决WordPress程序PHP版本过低的方法和思路

3、宝塔面板安装多PHP版本切换及不同站点设置不同PHP环境

本文出处:老蒋部落 » 解决安装网站主题出现"this will throw an Error in a future version of PHP"问题 | 欢迎分享( 公众号:老蒋玩运营 )