解决"make: *** [ext/fileinfo/libmagic/apprentice.lo] Error 1"

难怪之前有很多网友在使用WDCP面板升级"升级至PHP5.3.17"的时候提到有遇到编译不成功的问题,因为当时我测试是没有问题的,一直没有重视。刚才在帮助一个网友在阿里云服务器中安装WDCP面板且需要升PHP5.3的时候出现编译不成功,有提示make: *** [ext/fileinfo/libmagic/apprentice.lo] Error 1错误。

ext/fileinfo/libmagic/apprentice.lo] Error 1

出现这样的问题是因为有些VPS服务器内存小于1GB,导致编译占用资源不足,但也不是所有VPS出现这样问题的,有些低于1GB也是可以编译的。

解决方法:

第一、把老蒋上面的php_up53.sh文件下载到本地

第二、在./configure脚本后面加上

--disable-fileinfo

然后我们重新编译文件就可以。(老蒋把解决后的5.3版本脚本重新更新)

wget https://soft.itbulu.com/wdcp/php_up53.sh
sh php_up53.sh

我们这里再去使用就没有问题。

本文出处:老蒋部落 » 解决"make: *** [ext/fileinfo/libmagic/apprentice.lo] Error 1" | 欢迎分享( 公众号:QQ69377078 )