OpenLiteSpeed WEB服务器(一) - CentOS安装OpenLiteSpeed服务器环境

如果我们对于VPS/服务器环境部署稍微有些接触的,或者说是有接触过当前的主流WEB环境部署脚本的,肯定有听说过甚至使用过LiteSpeed服务器环境,尤其是在小内存、轻便型的WEB环境部署中,使用的LiteSpeed服务器环境比较多,包括在老蒋部落中也有提到的LLsMP一键环境包也是采用的这个环境。

不过,默认的LiteSpeed版本是属于商业版的,对于我们基本用户需求也是足够的,不过并发数只有150个,不过我们可以采用他的另外一个开源版本OpenLiteSpeed,是没有并发数限制的,而且功能上基本上足够我们普通用户需求。

在这篇文章中,老蒋将会分享OpenLiteSpeed环境的安装,以及PHP、MYSQL应用的部署,因为牵涉的内容较多,所以我准备分多篇撰写这个教程,在后面会涉及到OpenLiteSpeed环境建站过程,以及其他的组件部署和优化。

第一、部署OpenLiteSpeed服务器准备工作

根据官方的说法,我们可以在CentOS 5,6,7版本中是官方认可可运行的,也有用户在Debian Wheezy版本中测试通过,这里我们还是先根据官方的指导在CentOS环境中部署,后期老蒋在单独在我比较喜欢的占用资源较小灵活的Debian环境,好歹我们先看看是否可以成功,体验性能如何再深入挖掘。

第二、更新系统环境及系统源

yum update

这里我们为了确保系统获取的最新源版本,所以我们需要更新CentOS系统源。

第三、更新库及安装OpenLiteSpeed版本

# CentOS 5

rpm -ivh http://rpms.litespeedtech.com/centos/litespeed-repo-1.1-1.el5.noarch.rpm

# CentOS 6

rpm -ivh http://rpms.litespeedtech.com/centos/litespeed-repo-1.1-1.el6.noarch.rpm

#CentOS 7

rpm -ivh http://rpms.litespeedtech.com/centos/litespeed-repo-1.1-1.el7.noarch.rpm

我们需要先根据系统的发行版,更新库之后再安装OpenLiteSpeed最新版本。

yum install openlitespeed -y

然后执行上面命令安装最新版本的OpenLiteSpeed服务器环境,这里安装的是官方最新稳定版,如果我们需要指定其他版本安装可以这样操作。

如果还不好执行,那我们需要再安装一些依赖包:

yum -y install ncurses ncurses-devel glibc wget flex re2c unzip bison gcc autoconf autoconf213 automake mhash-devel cmake ruby file bzip2 bzip2-devel diff* libtool libtool-libs gcc-c++ libjpeg libjpeg-devel libpng libpng-devel libxml2 libxml2-devel curl curl-devel libmcrypt-devel freetype freetype-devel patch make zlib zlib-devel libtool-ltdl-devel expat-devel pcre-devel geoip-devel openssl-devel openldap-devel e2fsprogs e2fsprogs-devel krb5-devel libidn libidn-devel vixie-cron libevent libevent-devel

比如执行yum install openlitespeed-1.2.1命令就说明需要安装1.2.1版本,不指定版本号就是最新稳定版。这里老蒋在这台服务器上遇到点问题,获取不到最新版的环境包,那我就采用手工安装方法。因为我是边安装边记录文章的,所以全程遇到的问题也会记录下来,这样可以确保真实性,如果有遇到和我一样的问题,那就采用下面的手工安装。

wget http://open.litespeedtech.com/packages/openlitespeed-1.3.12.tgz
tar xzf openlitespeed-1.3.12.tgz
cd openlitespeed-1.3.12

这里我下载最新1.3.12稳定版,然后解压进入环境目录,准备编译。

./configure --prefix=/opt/itbulu/openlitespeed --with-openssl=/opt/itbulu --with-pcre=/opt/itbulu --with-zlib=/opt/itbulu

我们还需要编译OpenLiteSpeed安装路径,我喜欢直接安装在/opt/itbulu/openlitespeed目录下,如果默认则是在 /usr/local/lsws目录。执行过程中,也有提示出现OPENSSL错误问题(configure: error: Can not find openssl. You must install it before continuing.)这里我们还需要执行下面命令行。

LDFLAGS="-L/opt/itbulu/lib" CPPFLAGS="-I/opt/itbulu/include" ./configure --prefix=/opt/itbulu/openlitespeed --with-openssl=/opt/itbulu --with-pcre=/opt/itbulu --with-zlib=/opt/itbulu

执行完毕之后,我们还需要再执行一次configure部署,然后再执行部署编译整个环境,

make
make install
ldconfig

执行编译完毕之后,我们可以检查版本。

openlitespeed --version

如果检查不到我们当前安装的版本,肯定是有问题的,我们再解决问题。

第四、启动和暂停OpenLiteSpeed

#启动

/etc/init.d/lsws start

#暂停

/etc/init.d/lsws stop

默认安装的OpenLiteSpeed环境与我们的LiteSpeed一样端口是7080端口,直接IP:7080就可以打开WEB界面,默认用户名是admin,密码是123456,我们登录之后再进行调整。

CentOS安装OpenLiteSpeed服务器环境

总结,这样我们的OpenLiteSpeed服务器环境就安装完毕,后面我们只需要安装PHP版本以及MYSQL数据库就可以部署一个简单的站点。

本文出处:老蒋部落 » OpenLiteSpeed WEB服务器(一) - CentOS安装OpenLiteSpeed服务器环境 | 欢迎分享( 公众号:QQ69377078 )