OneinStack脚本Let's Encpty SSL证书未能自动续约解决办法

今天有网友反馈到自己在使用的OneinStack一键WEB脚本环境中使用的Let's Encpty SSL免费证书到期打开网站看到提示证书不可信任,一看浏览器证书标签已经过期十多天,看来这位同学的网站也不是经常去看。既然没有自动续约肯定是脚本存在一些问题,因为OneinStack脚本之前是存在这个问题的,我们需要升级到最新版本。

这里我们直接先升级脚本到最新版本,然后再升级10(acme.sh)到最新版本后退出。

"/root/.acme.sh"/acme.sh --cron --home "/root/.acme.sh" --force

然后再重新升级更新SSL证书后重启Nginx。

service nginx reload

这里我们重启Nginx之后就可以看到已经解决问题。以后再观察,如果还是没有自动续约,看再去看看其他问题。

本文出处:老蒋部落 » OneinStack脚本Let's Encpty SSL证书未能自动续约解决办法 | 欢迎分享( 公众号:站长事儿 )