一年一度儿童节更新一键脚本至LNMP 1.8 软件版本和优化升级

今天是六一儿童节,你有没有给自己或者给自己的孩子准备礼物?老蒋在WEB环境中还是比较喜欢使用军哥的LNMP一键脚本的,这款软件已经坚持更新好多年。而且有个习惯是每年的六月一日会有大版本更新。虽然在之前也有测试过他们的测试版,但是毕竟还是要等到正式版本出来。

一年一度儿童节更新一键脚本至LNMP 1.8 软件版本和优化升级

从软件版本上看,V1.8版本确实在原有的基础上增加不少的元素。其中就是兼容软件的版本大部分都是最新版本,比如PHP8.0,以及php-memcache支持PHP 8.0等等。我们一起看看官方的更新文档。


    增加PHP 8.0支持;
    增加Oracle Linux支持;
    增加WSL优化支持;
    增加phpmyadmin 5.0;
    增加CentOS6源自动调整;
    增加BuyPass、ZeroSSL SSL证书;
    增加php-memcache支持PHP 8.0;
    增加imagick支持PHP 8.0;
    增加apcu支持PHP 8.0;
    优化时间同步;
    优化Aliyunx Linux优化;
    优化sudo下添加虚拟主机SSL;
    优化CentOS8 Stream支持;
    优化PHP下载;
    更新诸多软件版本;
    其他一些功能优化及调整......

对于细节功能后面老蒋有机会再体验,后面我也打算把现有的WEB环境升级。但是考虑到新版本,而且虽然即便有测试版测试过,但是还是不太放心。我打算再等一个月升级到1.8版本,看看有没有其他官方更新补丁完善。

wget http://soft.vpser.net/lnmp/lnmp1.8.tar.gz -cO lnmp1.8.tar.gz && tar zxf lnmp1.8.tar.gz && cd lnmp1.8 && ./install.sh lnmp

这是LNMP V1.8安装程序脚本。

wget http://soft.vpser.net/lnmp/lnmp1.8.tar.gz -cO lnmp1.8.tar.gz && tar zxf lnmp1.8.tar.gz && cd lnmp1.8 && ./install.sh lamp

如果有需要安装LAMP也是可以的。

这里需要注意几个系统的选择问题。

1.安装MySQL 5.6或5.7及MariaDB 10必须1G以上内存,更高版本至少要2G内存
2.安装PHP 7及以上版本必须1G以上内存
3.PHP 7.4升级或安装必须CentOS 7+,Debian 8+,Ubuntu 16.04+且必须使用1.7!!!
4. MySQL 8.0.23以下版本升级或安装必须CentOS 8+,Debian 9+,Ubuntu 16.04+且必须使用1.7
5. MySQL 8.0.24以上版本升级或安装必须Debian 11+,Ubuntu 20.04+,Fedora 33+且必须使用1.8

我们在需要软件版本的时候,也是要对应镜像要求建议和系统要求支持的。

本文出处:老蒋部落 » 一年一度儿童节更新一键脚本至LNMP 1.8 软件版本和优化升级 | 欢迎分享( 公众号:老蒋玩运营 )