LNMP 一键安装包 V1.9发布 新增支持PHP8.1和增强模块

每年6月1日,是LNMP 一键安装包升级新版本的时间,今年也不例外有提供V1.9版本正式版发布,其实在早些时候老蒋已经有体验过他们家的测试版新版本,持续公测半年多。如果我们有在使用V1.8版本的也可以升级到V1.9,但是我们需要注意备份数据,万一出现升级兼容问题。

LNMP 一键安装包 V1.9发布 新增支持PHP8.1和增强模块

如果我们是新服务器安装LNMP 一键安装包的话,我们可以直接安装新版本。

wget http://soft.vpser.net/lnmp/lnmp1.9.tar.gz -cO lnmp1.9.tar.gz && tar zxf lnmp1.9.tar.gz && cd lnmp1.9 && ./install.sh lnmp

我们一起看看,LNMP V1.9版本有增加哪些内容。

LNMP一键安装包 V1.9正式版主要增加了对rocky linux 、alma linux、CentOS Stream 9及国产Linux(UOS统信、银河麒麟、华为openEuler、龙蜥Anolis OS)的支持;增加了exif、fileinfo、ldap、bz2、sodium、imap和swoole PHP模块选项,安装前可通过修改lnmp.conf中的对应选项的值为y开启或安装完成后./addons.sh 进行单独安装。增加了MySQL 5.7、8.0 二进制安装选项;增加了目前最新版的PHP 8.1支持及PHP扩展组件对8.1的支持;lnmp.conf增加了nginx模块ngx_fancyindex安装选项;lnmp管理脚本增加301选项及IPv6开启选项,泛域名SSL证书增加ZeroSSL免费SSL选项及一些安装代码优化。

具体表现在:

增加rocky linux 和alma linux支持;
增加PHP 8.1支持;
增加PHP模块exif、fileinfo、ldap、bz2、sodium、imap、swoole和SourceGuardian Loader的支持安装,安装lnmp前lnmp.conf 中开启后安装lnmp或 ./addons.sh 安装以上模块;
增加ngx_fancyindex模块,lnmp.conf中开启后,安装lnmp或升级nginx;
增加nginx模块--with-stream_ssl_preread_module,方便使用stream ssl相关配置;
增加UOS统信桌面家庭版、桌面专业版、服务器版支持;
增加银河麒麟服务器操作系统和桌面系统支持;
增加华为openEuler支持;
增加阿里巴巴龙蜥Anolis OS支持;
增加CentOS Stream 9支持;
增加Alma Linux 9支持;
增加MySQL 5.7、8.0 二进制安装和升级方式;
增加PHP 7.4+ webp支持;
lnmp管理脚本增加HTTP 301跳转HTTPS的选项;
lnmp管理脚本增加是否启用IPv6选项;
移除mariadb 10.1, 10.2增加mariadb 10.5, 10.6;
泛域名SSL增加了ZeroSSL支持;
优化AlibabaCloud支持;
优化部分SSL添加代码;
优化FTP用户添加部分代码;
优化离线安装;
优化部分EOL Linux发行版的安装;
优化OpenSSL支持;
优化RHEL 9系下uw-imap支持情况;
调整MariaDB升级下载地址;
更新诸多软件版本;
其他一些功能优化及调整......

 

本文出处:老蒋部落 » LNMP 一键安装包 V1.9发布 新增支持PHP8.1和增强模块 | 欢迎分享( 公众号:老蒋朋友圈 )

公众号 「老蒋朋友圈」获取站长新知 / 加QQ群 【1012423279】获取商家优惠推送